Como removo um pacote com o apt-get?

tempo de emissão: 2022-06-24

Para remover um pacote com o apt-get, use o seguinte comando:

apt-get remove nome do pacote1

Se você estiver removendo uma dependência de um pacote, use o seguinte comando:

apt-get remove nome do pacote2 depende do nome do pacote1

Para obter mais informações sobre como usar o apt-get, consulte a página man do apt-get.

Qual é o comando para remover um pacote e suas dependências com o apt-get?

O comando para remover um pacote e suas dependências com o apt-get é:

apt-get remove nome do pacote1 nome do pacote2 ...

Posso usar o apt-get para remover uma dependência específica de um pacote?

Sim, você pode usar o apt-get para remover uma dependência específica de um pacote.Para fazer isso, use a opção --remove ao instalar ou remover o pacote:

apt-get install pacote A apt-get remove pacote B --remove=dependency C

Se você deseja remover apenas uma dependência específica, também pode especificá-la como um argumento para a opção --remove:

apt-get install pacote A apt-get remove pacote B --remove=dependency C arg1 arg2 ...

O que acontece se eu tentar remover um pacote do qual outro pacote instalado depende?

Se você tentar remover um pacote do qual outro pacote instalado depende, o apt-get informará que o outro pacote está em uso e não será removido.Se o outro pacote não estiver instalado no momento, ele será instalado quando você tentar remover o pacote dependente.

A remoção de um pacote com o apt-get também removerá seus arquivos de configuração?

Sim, remover um pacote com o apt-get também removerá seus arquivos de configuração.Isso ocorre porque os arquivos de configuração são armazenados em um subdiretório do diretório do pacote.Por padrão, esse subdiretório é chamado de configs.Se você quiser manter os arquivos de configuração após remover um pacote, você pode usar a opção --keep-config ao executar o apt-get.

É possível reinstalar um pacote removido usando o apt-get?

Sim, é possível reinstalar um pacote removido usando o apt-get.Para fazer isso, primeiro identifique o pacote que deseja reinstalar.Em seguida, use o comando apt-get remove para remover o pacote do seu sistema.Finalmente, use o comando apt-get install para instalar o pacote novamente.

Como posso saber qual versão de um pacote será instalada pelo apt-get?

Se você deseja remover um pacote e suas dependências, use o seguinte comando:

apt-get remove pacote package1

Isso imprimirá uma lista de todos os pacotes que estão sendo removidos.O número da versão para cada um desses pacotes pode ser encontrado usando o comando apt-cache show.Por exemplo:

apt-get remove libxml2 Lendo informações de estado...Concluído Construindo árvore de dependências Lendo informações de estado...Pronto Os seguintes pacotes serão REMOVIDOS: libxml2 0 atualizados, 0 recém-instalados, 0 a serem removidos e 5 não atualizados.Após esta operação, 5 itens serão deixados em seu sistema.Você quer continuar?[S/n] y Removendo libxml

  1. .. pacoteN
  2. ..feito. 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 49 40 41 82 43 474 45 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 98 98 86 87 88 89 90 91 92 93 94 95 97 98 98 98 98 86 87 88 89 90 91 92 93 94 95 97 98 98 98 98 86 87 88 89 90 91 92 93 94 95 97 97 98 98 98 86 87 88 89 90 91 92 93 94 95 97 97 98 98 98 86 87 88 89 90 91 92 93 94 95 97 97 98 98 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 181 182 183 184 185 186 187 188 189 190 191 191 192 193 194 195 198 198 198 198 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 24445 246 247777777742 236 237 238 239 240 241 242 243 2445 246 24777777777777236 236 237 238 239 241 241 243 243 246 246 2477777777774444444236 236 237 239 239 241 241 243 244445 246 2477777777777444447 236 237 237 239 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 36 36 36 353 356 357 357 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 404 405 406 407 408 409 410 410 412 412 428 429 430 431 432 433 434 435 436 437 438 439 440 441442 443 444 445 446 747 448 499 500 501 502 503 504 506 507 508 508 501 510 510 512 512 513 51555 504 506 507 508 501 510 510 512 429 430 431 432 433 434 435 436437438439440441 Selecionando o pacote não selecionado anteriormente libxml (Lendo banco de dados ... 102753 arquivos e diretórios atualmente instalados.) Descompactando libxml2 (de .../li bxml2_9~dfsg-5ubuntu4_amd6deb) ...Configurando libxml2 (9~dfsg-5ubuntu ... Processando gatilhos para man-db (6 ... Configurando lsb-release (9etch) ...Configurando o dpkg (: Tentando determinar a arquitetura i38..

Como posso saber se tenho a versão mais recente de um pacote instalada?

Para determinar se você tem a versão mais recente de um pacote instalada, use o comando apt-get remove package.Este comando removerá quaisquer pacotes que sejam dependências do pacote especificado.Se o pacote especificado não estiver instalado, nenhum pacote será removido.

O exemplo a seguir mostra como usar o comando apt-get remove package para remover libgtk$ sudo apt-get remove libgtkSe você receber uma mensagem de erro informando que "Encontrada nova dependência: i386" ao tentar desinstalar um pacote com dependência de bibliotecas não encontrado em seu sistema, talvez seja necessário instalar essas bibliotecas antes de tentar desinstalar o pacote novamente usando o comando apt-get remove。

Você também pode usar o aptitude ou dpkg --list --installed | grep -E "^i[36m" para obter mais informações sobre quais bibliotecas são exigidas por um pacote específico。

Uma maneira alternativa de determinar se você tem uma versão desatualizada de um pacote de software é verificar a página de status do repositório online. Você pode fazer isso emitindo o seguinte comando de dentro da janela do seu terminal:

$ sudo aptitude update && sudo aptitude dist‑upgrade Lendo listas de pacotes...Concluída a construção da árvore de dependências...Pronto Os seguintes novos pacotes serão instalados: linuxmint 17 Xenial InRelease [569 kB] Obtido 569 kB em 4s (858 kB/s) Selecionando o pacote não selecionado anteriormente linuxmint17 InRelease .. Instalando o programa setuid root como /usr/bin/mint Atualização concluída com sucesso Atualizando informações de estado para linuxmint17 As seguintes tarefas PENDENTES estão pendentes de conclusão: #89 Compilando o linux Mint 17 MATE Desktop Environment #92 Limpando arquivos temporários Baixando Pacotes: 100% Completo Processamento de gatilhos para páginas de manual após a instalação Os seguintes NOVOS PACOTES serão INSTALADOS: ubuntu 1604 LTS amd64 0 atualizados, 0 recém-instalados, 2 reinstalados ou removidos e 3 não atualizados Verificação de transação em execução — Por favor, aguarde para instalar 10 pacotes no total .... $ sudo dpkg --status | grep -E "^ii[36m" ii Guia para iniciantes do Ubuntu 1604 LTS $ cat /etc/*release* ii Linux Mint 17 Tara $ cat /etc/*version* ii Linux Mint 17 Tara NVIDIA 396 Driver 39

  1. 0-0:
  2. 0-0 Lendo listas de pacotes...Concluída a construção da árvore de dependências...Pronto Os seguintes NOVOS pacotes serão instalados: libgtk0-0 0 atualizados, 1 recém-instalado, 0 a serem removidos e 2 não atualizados.Precisa obter 9 MB de arquivos.Após esta operação, 34 MB de espaço adicional em disco serão usados.Você quer continuar [S/n]?y Get:1 http://archive.ubuntu.com/ubuntu xenial InRelease [9 MB] Obtido 9 MB em 1s (11 kB/s) Selecionando o pacote não selecionado anteriormente libgtk0-. (Lendo banco de dados ... 11703 arquivos e diretórios instalados atualmente.) Descompactando libgtk0-0 (de .../libgtk0-0_1%3a4%3a20140626+dfsg1+Ubuntu16_amd6 ... Configurando libgtk0-0 (1:4~20140626+) dfsg1+Ubuntu16_amd6 ... Removendo a dependência de `libc6': Nova dependência encontrada: i386 Os pacotes que requerem esta biblioteca serão instalados mas não poderão ser atualizados até que tenham sido descompactados e configurados Falha ao instalar 'libc6' - falta(m) arquivo(s) necessário(s) )?
  3. *10041020beta3 amd64 $ dpkg --list | grep nvidia driver nvidia 39

Quais são alguns benefícios de usar o apt sobre outras ferramentas semelhantes como yum ou dnf?

Existem alguns benefícios em usar o apt sobre outras ferramentas semelhantes, como yum ou dnf.Primeiro, o apt é mais confiável e tem um longo histórico de uso em distribuições Linux.Segundo, ele tem um sistema de gerenciamento de dependência muito melhor do que o yum ou o dnf.Isso significa que você pode ter certeza de que os pacotes que você instala com o apt funcionarão corretamente juntos.Finalmente, apt é mais rápido que yum ou dnf ao instalar pacotes de repositórios.